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BVMS Upgrade fails on DIVAR IP with previously BVMS patches installed (An unexpected error occurred)

BVMS Upgrade fails on DIVAR IP with previously BVMS patches installed (An unexpected error occurred)

Possible causes and solution(s)

Symptoms

When upgrading BVMS (Bosch Video Management System) on some DIP devices with previously installed BVMS patches, the upgrade process fails after approximately 1 hour and 20 minutes. The system is unable to remove the previously installed patches, causing the installation to stop and timeout. This issue only occurs on some DIP devices.

BVMS Upgrade fails on DIVAR IP with previously BVMS patches installed (An unexpected error occurred).png

Scenario:

  • Installed BVMS Software Package 11.1.1, 12.0.1, 12.1.0 or 12.2.0

  • Installed BVMS patches on the installed version using System Manager

  • Started the upgrade to a higher BVMS version 12.0.1, 12.1.0, 12.2.0 or 12.3

  • Upgrade failed. BVMS appears with the previous version in the System Manager, despite the latest version being installed. VSG appears as installed in the System Manager, but it was actually uninstalled.

Causes

The issue is caused by the Windows Cumulative Update KB5015879 (released July 19, 2022). This update modifies the Remove-Item cmdlet in PowerShell, leading to "Access Denied" errors when removing patch folders, causing the installation to timeout.

Source: July 19, 2022—KB5015879 (OS Build 20348.859) Preview - Microsoft Support

All Windows Cumulative Updates released after KB5015879 include the change in the behavior and their installation will have the same impact as installing KB5015879.

 

Affected DIP devices:

  • DIP-44 (First Image with Windows Update KB5015879 or newer)

  • DIP-44 (Production Update Image)

  • DIP-64 (First Image with Windows Update KB5015879 or newer)

  • DIP-64 (Production Update Image)

  • DIP-74

Solution

This fix works both for users who have already attempted the upgrade and encountered errors, as well as for those planning to perform the upgrade for the first time. Executing this fix beforehand will prevent any errors during the process.

Manual Solution:

  • Open Windows File Explorer.

  • Navigate to: C:\Program Files\Bosch\SysMgmService\apps.

  • Delete folders starting with Bosch-VMS-Patch-for-BVMS.

  • Start or Retry the BVMS upgrade .

Command Line / PowerShell Solution:

  • Open the command line as an administrator.

  • Run: scoop list.

  • For each patch that start with the name Bosch-VMS-Patch-for-BVMS , run: scoop uninstall Bosch-VMS-Patch-for-BVMS-"Description".

  • Start or Retry the BVMS upgrade.

Automated Script Solution:

  • Extract the file fix_bvms_with_patches_upgrade.zip to a USB drive.

  • Run the fix_bvms_with_patches_upgrade.ps1 file (right-click on it and select "Run with PowerShell").

  • If the script is executed successfully, the message "Fix applied successfully. You can now update the software package through the System Manager." will appear.

  • Start or Retry the BVMS upgrade.

 

Conclusion

The issue is related to a specific Windows Update that changed the behavior of the Powershell Remove-Item cmdlet that in turn affects the way BVMS upgrade is being made.

All subsequent Windows Cumulative Updates include the changed behavior and will impact the the BVMS upgrade.

 

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