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Troubleshooting Project Assistant: MAC address not found or corrupt when scanning QR code

Troubleshooting Project Assistant: MAC address not found or corrupt when scanning QR code

Possible causes and solution(s)


  • Causes

When scanning a QR or Data Matrix code on a label using the Project Assistant app, it can happen that you get an error message that the MAC address cannot be found (1) or that only part of the address is correctly extracted (2).


  • Solution

First of all, there are different types of labels:

  1. product labels (on the device)
  2. box labels (on the outside of the box/packaging)
  3. installer / UX labels (inside the box /packaging)

Symptom (1) can only happen when scanning a product label because some QR or Data Matrix codes do not contain a MAC address, depending on the product, even though the MAC address is available in plain text right next to the code.


The box and installer label codes, however, always contain the MAC address information.

Symptom (2) can happen when scanning certain installer labels due to legacy formatting.


We have further standardized the labels so that the symptoms mentioned above will be resolved. There will be a transition period, however. As an alternative for symptom 1, you will have smooth experience when preferably scanning the box label. If you encounter symptom 2, we ask you to enter the MAC address manually or use the December 2018 release of the Project Assistant (version 1.2)

PS: For full transparency on QR code / Data Matrix content and/or troubleshooting purposes, you can use conventional code scanning apps available in the respective app stores.




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