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Fix black image of the camera connected to a VIDEOJET decoder

Fix black image of the camera connected to a VIDEOJET decoder



 

This article aims to define the way you can display camera video via decoders. Moreover, fifteen different settings scenarios and their effects will be outlined for the live video to be displayed through the decoder.

Article requirements:

  • BVMS
  • Camera
  • Decoder

Causes

VIDEOJET decoder doesn't show images of the cameras. image stays black


Solution

Please make sure that:

a. There is a user level password set on the cameras and the same password is set as destination password on the decoder.

The destination password (General password) setting is located in the decoder's "Advanced" menu and the "Destination" sub menu.  

 

Note:

  • The special characters used in the passwords meet the requirements of all components: BVMS, camera, decoder
  • The passwords are configured via the BVMS Configuration Client so that they are known to BVMS 

    Follow the steps below to view and change the passwords in BVMS Cc: 

    Open Cc --> Hardware --> Change device Passwords --> Check the "Show passwords" check box and you can easily see if the User level Password matches the Destination Password fields.

 

b. All devices added to BVMS are configured with "Secure connection" enabled.

Disable the secure connection on the decoder and cameras via the edit option, in BVMS Configuration Client

  • If 3rd party cameras are used, disable the secure connection on the VSG and the 3rd party cameras, as well, via the edit VSG/ edit Onvif decoder option 

c. Access Protection Enforcement: All devices have this security feature enabled by default. It is located in the "Service" menu, and "Compatibility" sub menu:


d. Disable the UDP encryption in the camera configuration itself when firmware used is 7.10 or higher 


Recommendations:

  • We would advise that the VJD and the cameras have the latest firmware installed, should there be no integration involved that requires a special project firmware, case in which you need to make sure that the firmware you use is compatible with that particular integration


VIDEOJET can’t upgrade the Firmware?

Please try to change HTTP/s in RCP+ from Configuration Manager.


Important additional information

  • The VIDEOJET decoder is not Onvif compliant. 3rd party Onvif devices can be displayed via the VSG (Video Streaming Gateway) on the decoder
  • With the release of BVMS 10, there are multiple settings ranging from "Secure Connection" to "Access Protection Enforcement" that can affect the ability successfully connect and display video on decoders.

ONVIF conformance

Conformance to ONVIF 1.02 and ONVIF Profile S provides interoperability between network video products regardless of manufacturer.
In addition, the firmware of the device supports all applicable features of the ONVIF 2.2 specification.
ONVIF conformant devices are able to exchange live video, audio, metadata, and control information and ensure that they are automatically discovered and connected to network applications such as video management systems

Also, for additional information regarding your product, you can always check the public product page where you can find the datasheet and latest firmware upgrades.

 

Connection Scenario Table





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